23rd March 2019

TimelessReborn Server Downtime

Identified

Issue identified by our team, a patch has been deployed.

Resolved

We'll continue to monitor the affected server.